Issue #9203 resolved

User unable to grant me admin access to their repo

Rod Bailey
created an issue

The owner of the repo at https://bitbucket.org/TsangR/rolloverisa has attempted to give me “admin” access to that repo.

My username on bitbucket is baileyr.

However I never receive notifications at the associated email address about a change in repo access, even though the email notification settings for my account indicate that I should be receiving emails when my access to a repo changes.

Neither do I see the repo listed in the “Repositories” list on my account’s Dashboard page.

For comparison, I tried creating a new bitbucket account with username johnglenn containing a single repo called JohnGlennTestRepo. Then I gave the baileyr account admin access to the JohnGlennTestRepo and everything worked as expected. I received an email notification that baileyr had just been given admin access to johnglenn/johnglenntestrepo and that repo started appearing in the “Repositories” list on my account’s Dashboard page.

Can you see any reason why TsangR is not able to give me (baileyr) admin access to his “rolloverisa” repo, but johnglenn can give me admin access to his johnglenntestrepo repository?

I am very puzzled.

Comments (4)

  1. Erik van Zijst staff

    How did TsangR add you? Using the Share button on the repo? And if so, did he use your email address or your username?

    Or did he add you to the repo directly using the repo admin's Access Management dialog? Again, did he use your email address or (mis)type your username?

    If he goes into the Access Management section on the repo in question, does he see the pending invitation? Can you attach a screenshot?

    To be honest, this is more of a support issue than a bug/feature request (which is what this issue tracker is for) and so maybe you want to contact support by emailing us at support@bitbucket.org with all the details I mentioned. It will be easier to take it from there instead of ending up with potentially confidential information on this public issue tracker.

  2. Log in to comment