1. Bitbucket Website
  2. Public Issue Tracker
  3. master

Issues

Issue #9263 resolved

Can not access forked repo error 500

salah ahmed
created an issue

I forked my private repo one-graphics (https://bitbucket.org/salahaa1/one-graphics) I tried to access the source on the fork (behanceYemen2014) I get (error 500 something went wrong ) .

Tried to clone the new fork from my IDE (netbeans ) I get error message .

regards

Comments (4)

  1. Erik van Zijst staff

    It appears as tough you have a corrupt changeset in your repo:

    # hg verify
    checking changesets
    checking manifests
    crosschecking files in changesets and manifests
    checking files
     data/application/views/behance.php.i@46: missing revlog!
     46: empty or missing application/views/behance.php
     application/views/behance.php@46: dffdf5a947a2 in manifests not found
     data/application/views/behance_1.php.i@46: missing revlog!
     46: empty or missing application/views/behance_1.php
     application/views/behance_1.php@46: a1ed30199610 in manifests not found
     data/behance.html.i@46: missing revlog!
     46: empty or missing behance.html
     behance.html@46: adbaf1317c81 in manifests not found
    2419 files, 48 changesets, 3304 total revisions
    9 integrity errors encountered!
    (first damaged changeset appears to be 46)
    

    To fix this, we'll have to strip the broken changeset (46 -- 6fd47dfcad5527f63b9d0aab268ff867a6ec04ad). You can try to this yourself on the repo admin page. Let me know if that fails, in which case I can do it on the server side.

    You'll also want to check the integrity of your local repo. If your local clone is fine, you can push up the changesets 46 and 47 after you stripped them on our side and you should be all good to go.

    If your local repo also contains the corruption, you'll have to strip the changeset there, too:

    $ hg strip 46
    

    For more detailed information on dealing with corruption in Mercurial, have a look at: http://mercurial.selenic.com/wiki/RepositoryCorruption

    Let me know if you need any help.

  2. Log in to comment