Issue #9354 duplicate

Source Editor not working for Android Devices

geoff-grav
created an issue

This happens in both Github and BitBucket. When using an Android Device and selecting Edit on a Source file the Editor does not work. I can't use the Backspace to remove any characters. It also gets glitchy when trying to add characters. I tried setting the Editor to "Plain Text" mode, but that does not help. I have tried many devices and many browsers for the Android Devices and all seem to have the same issues.

Is there any way that you can support a Simple "Edit in a Textarea field". Just detect the device and if it is a mobile/Tablet device that you can show this option at the bottom next to editor mode and indent mode. It doesn't need to be fancy. No need for syntax highlighting, line numbers, special tab indentation, etc. Just a simple plain text option. This should also resolving scrolling issues as it it very difficult to scroll through divs in mobile devices.

Thanks in Advance

Comments (3)

  1. Log in to comment