1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #9397 resolved

SourceTree Git Clone Error

Elisa Erriquez
created an issue

Hi, One of my developers has encountering an issue while trying to clone our repository.


This is the error git -c diff.mnemonicprefix=false -c core.quotepath=false clone --recursive https://AjayBihariVerma@bitbucket.org/mouchel/taranto.git D:\TSL_BitBucket Cloning into 'D:\TSL_BitBucket'...

fatal: early EOF

fatal: The remote end hung up unexpectedly fatal: index-pack failed

error: RPC failed; result=18, HTTP code = 200

Completed with errors, see above.


Some other times, the clone just hangs there without actually progressing, for hours and hours. We have tried this multiple times.

We have followed the steps in https://confluence.atlassian.com/pages/viewpage.action?pageId=301663284 and I have attached the log file from the console.

It reached 13% and just hanged there.

Please let us if you can help.

Comments (39)

  1. Mario Baldini

    Hello,

    I'm having the same issue in a Windows machine using SourceTree.

    Strangely, other linux machines work seamless and even there's another one using Windows/Sourcetree that works fine. The problem is only in a specific, recent installed, machine. (Antivirus is off and there's no special config. It's a default Win7 install).

    I even thought that the OS was corrupted somehow and reinstalled it. But after a fresh install/full update of Windows 7 x64 Pro; and SourceTree 1.5.2.0 (using embeded git) it freezes when cloning a repo.

    We have tried to clone it several times (20+), for over 3 weeks. Since other computers running linux can clone it normally, I don't think that it's a temporary issue regarding site performance, but something related to recent versions of Windows/Sourcetree.

    Could someone please advise what could I try to fix this?

    Thank you

    git -c diff.mnemonicprefix=false -c core.quotepath=false clone --recursive https://mariobaldini@bitbucket.org/attosistemas/attofm-firmware.git C:\Users\DellAIO\Documents\attofm-firmware Cloning into 'C:\Users\DellAIO\Documents\attofm-firmware'...

    fatal: early EOF fatal: The remote end hung up unexpectedly

    fatal: index-pack failed

    error: RPC failed; result=18, HTTP code = 200

    Completed with errors, see above.

  2. Hye Jeong Yun

    One of my team has the same issue in windows 8 using Source Tree with BitBucket. I tried to clone repo several times on her machine for over 2 weeks. Every time, it failed. A month ago, it was successful. So she has used our project. 2 weeks later, she tried to pull our project. but failed.
    So she and I have tried to solve that problem while removing repo and cloning repo, but we could never make successful cloning again.

    I think there can be a change in your Source Tree server or something else recently. If not, please give me some advice.

  3. Mario Baldini

    I temporarily fixed the issue in the Windows host with the command by William Mo.

    If it's still happening in recent versions, it should be marked as a unresolved bug. It you install the software and need to do extra tweaks, I don't think that is 'resolved', as they closed the issue.

    git config --global http.postBuffer 524288000
    
  4. David Harms

    This isn't resolved - been hung on this same issue for a week with another developer. He cannot clone our 1.4gb (already size optimized) repo and it always stops at 1GB. Please help!

  5. Jim Wells

    fatal: The remote end hung up unexpectedly fatal: early EOF fatal: index-pack failed

    Tried to clone 6 times on mac and windows... If you watch the Activity monitor, git stops downloading at exactly 1GB. Some new bitbucket DL size restriction for new users? Have tried to clone in terminal and sourcetree, so I know it's not a sourcetree issue

  6. xuan ta

    Last time, I had the same problem, but now, it's ok with me. The problem is our internet problem. Please go to any place which have good internet bandwidth.

  7. Sagar Dahal

    Same problem here. I've been trying to clone a repository for two days. It isn't the bandwidth because everything else is running smoothly. Tried the postBuffer method, no luck.

  8. igame thou

    Same problem with Ubuntu Server 14.04 + gitlab 7.1.1 but disappeared after updated gitlab.

    I have two big repos: one is 1.4G and another is 400m+. The ssh clone was ok but http wasn't. I attempted the following git parameters, but it only worked for 1.4G repo. I guess that the 1.4G repo has smaller files then 400m repo. ... http.postbuffer=524288000 http.lowspeedtime=3600 core.compression=0 core.packedgitlimit=2048m core.packedgitwindowsize=2048m pack.windowmemory=1024m pack.packsizelimit=1024m pack.deltacachesize=1024m ... I also tried set any timeout values which probably are relating to gitlab & nginx to 300 or greater(like 3600), but looks like they only affect on 1.4G repo.

    Finally I'm tired and decided to update to gitlab from 7.1.1 to 7.6.2. Now everything is Ok and I'm happy again.

  9. Sam B

    Michael Frauenholtz great job marking an open issue as resolved, Atlantis support is top notch!

    /asmuchsarcasmasicanpossiblymusterintoatextbasedcomment

    can't wait to move to github.

  10. Darren Seet

    Just for anyone who face this error. I had a scenario where I am based in Asia doing a VPN into US to clone a Slash repo based in US using SourceTree Git. As it was using https over a very slow VPN connection for a big repo the process failed. The solution to increase the http.postBuffer did not solve the issue in this scenario.

    In the end the solution was to use command line git and switch the protocol from https into ssh, so the repo address was ssh://account@xxxx.com

  11. Bhartendu Sharma

    I also got the same error when I tried to clone the Repo. I tried to clone for about 20 times but got the same error message.

    But when I tried once again when my internet was little fast then I got success to clone the repo. It seems that internet should be fast to clone the repo.

    Thanks

  12. Dave Milton

    I cannot clone a repo and get the following:

    warning: templates not found C:\Users\Dave\AppData\Local\Atlassian\SourceTree\git_local\share\git-core\templates

    fatal: early EOF

    fatal: The remote end hung up unexpectedly

    fatal: index-pack failed

    Completed with errors, see above.

    I have tried various different destinations without any success. It actually ends up only grabbing 308 bytes every time if that is a clue to someone?

    Any help/advice/tips would be greatly appreciated.

  13. Vasily Domashev

    And this issue marked as resolved ?????

    Tried clone rep on 2 windiws machine absolutly same error

    warning: templates not found C:\Users\vasily\AppData\Local\Atlassian\SourceTree\git_local\share\git-core\templates

    fatal: early EOF

    fatal: The remote end hung up unexpectedly fatal: index-pack failed

    Completed with errors, see above.

    What should I do???

  14. Log in to comment