Import Git Repo Not Working

Issue #9420 resolved
created an issue

I'm in the process of importing a bunch of git repositories from Assembla into BitBucket. It was working fine until about an hour ago, at which point the Import tool stopped working.

I would select "Git Repo" for both the Old and New Repositories. Under just Old Repository, I provide the Assembla git URL, username, and password. Under just New Repository, I set the repo name, language, and set the owner to a team.

Upon hitting "Import Repository," I get the following error message:

The source and destination scm must match.

I can't get past this error message to import the repositories.

Comments (2)

  1. gmodevops reporter

    Looks like this might be a browser or Javascript problem. I was encountering this issue in Firefox. When I launched a Chrome instance and tried again there, the imports worked. The user interface also looks different (Icons in the owner menu, other javascript effects).

    I'm using Chrome 34.0.1847.131 and Firefox 28.0

  2. Michael Frauenholtz staff

    Hi @gmodevops

    Thanks for letting us know. If this is working for you again, I'm going to mark this ticket as resolved. The import page does rely on javascript to set the source and destination properly, so that could cause issues if not working properly. If you do notice this again in the future, feel free to reopen this issue and we'll take a deeper look.


  3. Log in to comment