1. Bitbucket
  2. Public Issue Tracker
  3. master

Issues

Issue #9439 resolved

Overview : Unable to load a pull request

calve
created an issue

Hi, I experienced the following bug a couple of times :

Create a pull request from myrepo/branch-0 to upstream/branch-0 (new branch)

Everything looks fine in diff.

Lead developer wants to merge it, he and I get "We were unable to load this page." in overview while commit list is correct.

So I tried to create a new PR, but since its the same source to the same destination, it just redirect me to the old PR, which doesn't get updated in anyway.

Lead dev merged it in upstream, and now the overview is fine

Please let me know if you need extra informations

Comments (31)

  1. Ricardo Ferreira

    calve I'm not sure if it's your case too, but in our case I solved it by created the branch in the repo that I wanted to push. It seems that the bug is triggered only when you try to create a new branch from the pull request.

    I hope it helped.

  2. calve reporter

    Yes, manually creating the destination branch in the upstream solve the issue (ie, the overview is filled) Indeed, the bug seems triggered only when the destination branch does not exists. Everything where fine before the "pull requests now automagically updates" update I guess.

  3. Fili Wiese

    I can confirm the same error. If I create the branch on my local machine using mercurial and then push this branch to bitbucket I am able to review the code in the pull request. Without this I am unable to load the changes in the pull request.

  4. Fili Wiese

    BTW this is a new bug as I have it also with an old pull request I was able to review in the past (and commented on) but now am unable to load (pull request is still open and was not yet merged or approved)

  5. calve reporter

    Hi Dan, I tried to reproduce the bug on one of your repo, and cannot reproduce the bug either. Maybe it only affects private repo ? For information, as I only use git, I don't know if this bug affects Hg too. Should I send you a link to a private pull requests by email ?

  6. Ricardo Ferreira

    Well in our case, it was in a git repository and it was in a private. So I would believe that you should verify agaisnt a private git and hg repo. Maybe you can get a better look there.

  7. Adam Munoz

    This bug is happening to us on all our pull requests, everyday. It happened after the migration to the new servers that Bitbucket did recently. Not sure it is related though.

    Dan Bennett please get in touch if you need examples of the bug

  8. Rahul Raveendran V P

    The problem now is that my colleagues who work on the same project faces the same issue. None of them are able to create a PR that does not have this issue.! Also it does not show the layout with diff that used to come when u create a new pull request. Even the "Close branch_name after the pull request is merged" check box is shown as disabled.

  9. Log in to comment