1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #9593 resolved

"Clone in SourceTree" button broken (BB-10694)

Yordan Gigov
created an issue

Before the design change clicking the "Clone" button used to give a small block with a clone command you could copy. It currently does not work under Firefox 29.0 or Chronium (and probably Google Chrome)

Comments (26)

  1. Yordan Gigov reporter

    There are no errors, but some warnings in the console. It seems to work right under Windows. It doesn't work in Debian. Here's a copy of the console output

    Consider using 'dppx' units instead of 'dpi', as in CSS 'dpi' means dots-per-CSS-inch, not dots-per-physical-inch, so does not correspond to the actual 'dpi' of a screen. In media query expression: only screen and (-webkit-min-device-pixel-ratio: 1.5), only screen and (min-resolution: 144dpi) 
    Consider using 'dppx' units instead of 'dpi', as in CSS 'dpi' means dots-per-CSS-inch, not dots-per-physical-inch, so does not correspond to the actual 'dpi' of a screen. In media query expression: only screen and (-webkit-min-device-pixel-ratio: 2), only screen and (min-resolution: 144dpi) 
    10
    Consider using 'dppx' units instead of 'dpi', as in CSS 'dpi' means dots-per-CSS-inch, not dots-per-physical-inch, so does not correspond to the actual 'dpi' of a screen. In media query expression: (-webkit-min-device-pixel-ratio: 2), (min-resolution: 192dpi) 
    event.returnValue is deprecated. Please use the standard event.preventDefault() instead.
    DEPRECATED: onTop has been replaced with gravity - See https://ecosystem.atlassian.net/browse/AUI-2197 aui-stable.js:415
    2
    DEPRECATED: displayAbove has been replaced with gravity - See https://ecosystem.atlassian.net/browse/AUI-2197 aui-stable.js:415
    
  2. Zachary Davis

    This button should not be displayed at all for users running Linux. It is for cloning a repository in SourceTree, which is not supported on Linux. I'll be putting out a fix for this shortly.

    Note that you can always access the clone url from the overview page or the full clone command from the repo sidebar.

  3. Prabha Rajagopalan

    I faced the same issue recently. My system configuration is as follows:

    OS : Windows 7 (64 bit) SourceTree version : 1.9.5.0 Google Chrome version : 52.0.2743.116 m (64-bit)

    Nothing was happening when I clicked the 'Clone in Source Tree' button. What worked for me was :

    Open SourceTree -> Click on Tools -> Options -> in General tab, check "Use this version of SourceTree for URI association"

    This problem is not always reproducible though. I'm not sure why. Zachary Davis : I request Atlassian team to look into this issue.

    Hope this helps. Thanks.

  4. Log in to comment