Reported repository size seems wrong

Issue #9602 resolved
Pavel D
created an issue

Hi, we have a repo,

And it now displays this message: This repository's size is over 1 GB. Read more on how to reduce the size of your repository.

As well as reports the repo size to be 1.4GB. However, when I run this:

git count-objects -v -H I get size-pack: 141.88 MiB

How can this be?

Comments (25)

  1. Brodie Rao

    Hi Pavel,

    It looks like your repository has a lot of data in pack files that's either redundant or no longer being used. Due to the way we have Git's garbage collector configured, it didn't clean up that data.

    I've forced garbage collection on your repo, it should report being 143 MB in size. I've also filed an internal issue to address this general problem.

  2. Jake Logemann

    Hi @Brodie Rao

    Currently, I am unable to push to origin on the master branch. It appears that there is a permission denied error when git appends to the remote ./logs/refs/heads/master file. I have verified that the file has correct permissions on my end, perhaps the file was modified with root or something similar?

    For now, I have been able to push to an alternate branch, let me know your thoughts.

    Thanks! Jake

  3. Pete Eveleigh

    Having this issue too. Repo was very large (1.6GB) but I've cleaned it up and now when I run git count-objects --v I see the size-pack as being 198838. The repo info screen still says that it's 1.6GB.

  4. Giuseppe C.

    This issue seems to be still not resolved, I have the same issue as Pete Eveleigh. I e-mailed to the support-team and hope that this will be resolved soon. Thanks!

  5. Andrew Weddle

    I also am still facing this issue. Repo was 2GB+, but now reporting size-pack: 47094. However I still get the "This repository's size is over 1 GB." message. Have emailled

  6. Jurgen Hannaert

    We encountered this issue as well. 28MB, but 1.4GB according to Bitbucket web ui.

    git count-objects -v -H
    count: 0
    size: 0 bytes
    in-pack: 2459
    packs: 1
    size-pack: 28.62 MiB
    prune-packable: 0
    garbage: 0
    size-garbage: 0 bytes
  7. Rudolf Rosa

    Issue still there, "git count-objects -vH" says it's 735 MB, but online it says it's 4.5 GB and set to readonly (how could we even get to 4.5GB when the limit is 2GB?!). This is a major blocker of our work, so we are leaving bitbucket for good. No time to discuss things manually with the support, that'ts not how it should work.

  8. manju

    We too encountered this issue as well for our repo
    Looking at the warning message we shrinked our repo on 11-03-2017
    After shrinking, the size is as follows
    git count-objects -vH
    count: 0
    size: 0 bytes
    in-pack: 25575
    packs: 1
    size-pack: 194.13 MiB
    prune-packable: 0
    garbage: 0
    size-garbage: 0 bytes

    And our folder size is : du -hs anusaaraka == 607MB

    We have emailed on Mar 13 2017 But still we get the "This repository's size is over 1 GB." message.
    Kindly fix this issue.

  9. Leonardo Bell

    Still seeing this issue with one of our private repos on bitbucket cloud.

    [leonbe02]$ git count-objects -vH
    count: 1255
    size: 37.21 MiB
    in-pack: 6160
    packs: 41
    size-pack: 241.13 MiB
    prune-packable: 175
    garbage: 0
    size-garbage: 0 bytes

    Every couple days, we'll get a warning from bitbucket saying our repo is over the limit. When I check the size on the bitbucket site, it will say something ridiculous like 4.5gb. When I merge a branch into master or delete an old branch, it seems to trigger a garbage collection and when I check the size again, it goes back down to its actual size (241mb).

    Seems to still be an issue with Bitbucket's auto garbage collection process.

  10. Phil Gooch

    Same issue here. Followed all the steps at length to reduce the repo size, enabled LFS, locally the clone repo size is now only 36KB, but Bitbucket is reporting 1.8GB!

  11. Jesse Yowell staff

    Phil Gooch-- you can open a ticket at for this. It's more than likely we'll need to do a quick cleanup on our side, just mention the account / repo and we'll do that for you

  12. Leonardo Bell

    Ideally we wouldn't need to open support tickets and have our repos cleaned manually when this happens. Why do the Bitbucket repo size quotas take into account the garbage size when we have no control over when the garbage collection process occurs? I've had to completely abandon repos on Bitbucket cloud due to Bitbucket forbidding me to make any updates to a repo that is over the 2GB limit, when in reality my repo was only 250mb after garbage collection.

  13. Log in to comment