1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues


Issue #9780 resolved

Team Menu (dropdown) doesn't get properly initialized (BB-10957)

Matthew Rose
created an issue

Tried doing a search for a ticket similar but couldn't find one.

The teams menu (drop down menu) located between Dashboard and Repositories does not contain all the teams that I am a member of. Currently I am a member of 3 teams and I can only see a link to the team that I created.

This is how I as a user would expect the menu to function. Given on any page within Bitbucket when clicking the teams menu then I see all teams I am a member of.

It also seems that sometimes when on the dashboard the teams menu will tell me to create my first team or list no teams.

Comments (11)

  1. Chris Somme staff

    Hi Matthew,

    Based on your description I'm guessing that you're running into a peculiarity of the way that the bitbucket permission system interacts with team membership. I'm going to mark this as a duplicate, but reopen this issue if it doesn't seem that your situation matches the description of the other issue.

  2. Matthew Rose reporter

    Hi Chris,

    I have read through the duplicate post and am not sure that this is my issue. Potentially the permissions peculiarity mentioned contributes to this, but I still feel the UI is confusing. The focus in that ticket is about emails and mine is the UI, so I do not feel that its a duplicate. I have prepared some screenshots for this, here I have had to rename the other two teams and their projects using the inspector but you should still get the idea.

    My issue is that the teams menu (which i have open in the below screenshot) does not contain the other two teams I am a member of .. Screen Shot 2014-06-27 at 19.29.23.png Its important to note that we are looking at the drop down. The dashboard overview is showing the correct information, I have even selected the "teams" filter which shows me almost what I am expecting to see the the drop down.

    • gunship is my team, I have create and write access.
    • china is my friends team, I have only read access but on ALL repositories.
    • japan is my companies team, I have no "create" repository access but full read/write on most repositories.

    For an example, I see that you are a member of 6 teams, so if i was logged in as you then I would expect that 6 teams show in my drop down. If i was going to add you to my team with read access I would expect you see "gunship" in your team menu.

    So to go back to my original user story. Given on any page within Bitbucket when clicking the teams menu then I see all teams I am a member of. I feel this still stands true.

    On a side note, the infrastructure guys who manage our team and create our repositories for us do see the "japan" team in their listing.

    Now, I mentioned lastly that there was this bug where the team menu would appear to "forget" my teams. Here is a screenshot of that too. To replicate this I refreshed the page and clicked the team menu. Screen Shot 2014-06-27 at 19.29.41.png

    I hope this is enough information to either get a fix or work its way in to a feature.

  3. Chris Somme staff

    I opened a new internal issue specifically to address the problem with the menu not being populated at all, that is a separate issue.

    I realize that the issue that I had marked it as a duplicate of involved emails and not specifically the team functionality that you reference, but they have the same underlying cause. The referenced bug explains why things work the way they do now. If you don't have either 'can administer account' or 'can create private repo', you're not considered part of the team for the purposes of displaying the team in that drop down.

    I do understand the confusion around how team membership works. As noted in that original bug, there is another internal issue already open to track the feedback about how team membership is displayed. We will take your feedback into consideration as we evaluate that issue.

  4. Rickard Nord

    I can confirm that if you are a member of a team (my definition is that if you at least have write access to one repo, you are a team member) and the group you belong to does not have either:

    • ability to create repos under the team nor
    • ability to administer the account

    only read/write access to the repos therein, you are not considered a member of the team and the team does not appear in the "Teams menu".

  5. Jonathan Poh staff

    Hi Matthew,

    Chris and Rickard have both described how the Teams functionality works, but in addition to that, with the recent release of Projects for organisation of repositories, the Dashboard has also been redesigned. The filter bar now has a 'Owner' filter which covers your use case of showing repositories that belong to yourself as well as teams which you have been given repository access to (but not necessarily a Team membership with 'admin' or 'create' permissions).

    The other issue with the Teams (and the other) menus getting 'stuck' and thinking you don't have any has also recently been fixed and shouldn't happen anymore.

  6. Matthew Rose reporter

    Thanks, I shall take a look at those.

    I guess with the addition of projects people are too busy clicking in circles and being confused by the endless "Untitled Projects" now to even notice the team menu not working properly.

  7. Log in to comment