1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #9784 resolved

Push Hangs "abort: HTTP Error 500: Internal Server Error"

Jason Bentley
created an issue

I attempted to push a rather large group of files and then realized quit the push when it was obviously not going to go through in a timely manner.

I then backed everything out and started with a simple change on my PC. It just hangs.

I went back to the Mac that I had made the last change with and tried a simple change there. It errors out and gives the error:

"abort: HTTP Error 500: Internal Server Error"

I've seen bugs from other people who have had the same issue, but no solutions other than an Admin resetting the bad push in the repository.

Comments (6)

  1. Chris Somme staff

    Hi Jason,

    Your repository was corrupted on our side as a result of the aborted push. I have run hg recover and hg verify on the repository, and that should have fixed it. Try and push again.

  2. Chris Somme staff

    It's not a bad idea to run it locally to make sure that your copy of the repository isn't corrupted. But it wouldn't solve this problem, we need to run it on our copy of your repository. I just wanted to let you know what we did.

  3. Log in to comment