1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #9976 closed

Colon as separator between host and organization is invalid

Till Klocke
created an issue

Currently we are trying to use some private bitbucket repositories with the repo tool from google. The problem is that bitbucket uses a colon (":") as the separator between the host and the organization. This leads to the situation that linux handles the organization name as service identifier which it tries to lookup. Even if it can successfully lookup this identifier (for example if you modify /etc/services) the portion of the repo url with the organization name is lost and git probably tries to connect the wrong port. I can imagine since the colon has a reserved meaning in URLs that other tools will run into the same issues. It would be nice if this gets fixed in the near future as this problem is currently a blocker for us. Using the https URLs is no alternative since these are user specific for private repos.

Comments (4)

  1. Kaleb Elwert

    Have you tried using ssh://git@bitbucket.org/username/repo for the repo location?

    This is an alternate way of cloning with git over ssh which doesn't require the usage of a : in the name.

  2. Till Klocke reporter

    Thanks, I tried that and it seems to work. You can just use the organization name instead of the username. This notation should probably be more visible on the repo pages.

  3. Log in to comment