Commits

Mattijs Hoitink committed fc54225

Swapped argparse module for optparse module

To lower the minimum python requirements the argparse module (2.7+)
is swapped for the optparse module.

Comments (0)

Files changed (1)

 #!/usr/bin/env python
 
-import sys, os, argparse
+import sys, os, optparse
 
 # Ugly hack so I can code in peace.
 try:
 
 if __name__ == '__main__':
 
-    # Argument parser
-    parser = argparse.ArgumentParser(description='Markdown files to documentation. Run and get on with your life.')
-    parser.add_argument('-s', dest='source', default='.', help='Documentation source', metavar='SOURCE')
-    parser.add_argument('-t', dest='target', default='./build', help='Documentation output target', metavar='TARGET')
+    # Option parser
+    parser = optparse.OptionParser(description='Markdown files to documentation. Run and get on with your life.')
+    parser.add_option('-s', dest='source', default='.', help='Documentation source', metavar='SOURCE')
+    parser.add_option('-t', dest='target', default='./build', help='Documentation output target', metavar='TARGET')
 
-    args = parser.parse_args()
+    (options, args) = parser.parse_args()
 
     # Render with arguments
-    render_files(args.source, args.target)
+    render_files(options.source, options.target)