1. Steve Losh
  2. hg-review
  3. Issues
Issue #44 resolved

Windows support, lol.

Steve Losh
repo owner created an issue

No description provided.

Comments (10)

  1. chen.hendrawan

    Hi Steve,

    Glad you are planning to support Windows users :)

    I have a bit problem here. First when I run hg review --web I get the error "abort: No module named Cookie!" I was using TortoiseHg setup. I managed to work around this error by installing Phyton windows installer, then modifed the web.py file to include this line

    sys.path.append('C:\\Python27\\Lib')
    

    Now I can run the web interface. Then I fall into different problem. Then file content of the changeset is not displayed. Only "… no lines to show …" message. Also can not add comment, etc. Please help.

  2. Steve Losh reporter

    Hey, the second problem (no lines to show) should be fixed.

    The first problem is much more strange, and I'll need a Windows expert to help me figure out why that module isn't being loaded.

  3. Benoît Allard

    Ok, I've got it running on WinXP without Python installed, only THG.

    Those are the modules that are not shipped with THG and that I would suggest can be bundled same as the rest:

    Werkzeug needs:

    • Cookie
    • htmlentitiesdefs

    simplejson needs:

    • decimal
    • numbers

    Markdown2 needs:

    • uuid

    Nice work !

  4. chen.hendrawan

    I confirm that after using the windows Python update script from Daniel Newton, the problem went away. Thanks!

    Benoît, install Python, then run the script in hg-review/contrib/windows/update_tortoisehg_libs.py.

    I tested on Python 2.7 by slightly modified the script.

  5. Alex Muravya

    Same problem

    I did: 0) cloned repo 1) modified my hgrc 2) cd to cloned repo and tried to run "hg review --web"

    It failed. After reading this issue, I did: 1) installed python 2.6 (+ added path to python.exe to PATH) 2) run script the script in hg-review/contrib/windows/update_tortoisehg_libs.py. 3) and finally tried to modify web.py with line sys.path.append(E:
    my
    path
    to
    python
    here)

    Same error occures all the time:

    E:\CodingApps>cd hg-review

    E:\CodingApps\hg-review>hg review --web * failed to import extension review from E:\CodingApps\hg-review\review\: No m odule named hg: unknown command 'review' Mercurial Distributed SCM ...

    My OS - Windows 7 Ultimate (x86_64), python 2.6.6 (64-bit), THG installed, Mercurial Distributed SCM version 2.2.3

    Any workaround in my case?

  6. Log in to comment