#60 Merged at ee82c5e
Repository
f_x
Branch
4.05
Repository
skskeyserver
Branch
default
Author
  1. ygrek
Reviewers
Description

I think it is a better fix for issue #49 than pull request #56 or the debian patch from https://bugs.debian.org/870150

Checking that it doesn’t break other builds : https://travis-ci.org/ygrek/sks-keyserver/builds/412474059

  • do not use UnixLabels without need (avoids breakage with 4.05)
  • Makefile: limit camlp4o usage by ocamldep
  • silence deprecation warning for lowercase/uppercase
  • do not match against exn strings
  • Issues #49: SKS is incompatible with ocaml 4.05 new

Comments (6)

  1. Yaron Minsky

    This does not look ready to merge, due to the conflicts. Happy to merge if that’s resolved.

  2. ygrek author

    Merged default so now this branch should be ok. I wonder if there is any chance to switch repo to git?

  3. Yaron Minsky

    Apologies. I don’t really watch this repo anymore, but the patch looks good to me. I’ll merge.