1. slepc
  2. SLEPc
  3. slepc4py

Overview

HTTPS SSH

SLEPc for Python

Overview

Welcome to SLEPc for Python. This package provides Python bindings for SLEPc, the * Scalable Library for Eigenvalue Problem Computations*.

Dependencies

  • Python 2.6, 2.7, 3.2 or above.
  • A recent NumPy release.
  • A matching version of SLEPc built with shared/dynamic libraries.
  • A matching version of PETSc built with shared/dynamic libraries.
  • A matching version of petsc4py.
  • To work with the in-development version, you need to install Cython.