Internal Error while opening a repo

Issue #47 open
Anonymous created an issue

While opening a rather big repository with 2000+ changes (converted into using mercurial long time ago, at revision ~700), Murky throws an internal error and crashes.

Mercurial 1.2.1, Murky 0.5, MacOS X 10.5.7

I tried lots of tricks, created a new blank repo with murky, then over-wrote it with my big repository, tried cloning my big a repo into new one with murky, but it doesn't work.

Here is the trace:

Uncaught exception: NSInternalInconsistencyException Assertion failed: Unexpected revision numbers from log: expected starting 0, got 2150

-[HgRepository _checkRevisions] (in Murky) + 655
-[HgRepository revisions] (in Murky) + 76
-[NSObject(NSKeyValueCoding) valueForKey:] (in Foundation) + 250
-[NSObject(NSKeyValueCoding) valueForKeyPath:] (in Foundation) + 474
-[NSObject(NSKeyValueCoding) valueForKeyPath:] (in Foundation) + 320
-[NSBinder _valueForKeyPath:ofObject:mode:raisesForNotApplicableKeys:] (in AppKit) + 876
-[NSBinder valueForBinding:resolveMarkersToPlaceholders:] (in AppKit) + 192
-[NSArrayDetailBinder _refreshDetailContentInBackground:] (in AppKit) + 416
-[NSBinder _performConnectionEstablishedRefresh] (in AppKit) + 79
-[NSObject(NSKeyValueBindingCreation) bind:toObject:withKeyPath:options:] (in AppKit) + 744
-[NSNibBindingConnector establishConnection] (in AppKit) + 166

Comments (5)

  1. Jens Alfke repo owner

    Could you set the Murky user defaults "Log", "LogHgLog" and "LogHgRepository" all to YES, run this again, and then attach the console output? There should be a bunch of debugging stuff that will be helpful in diagnosing this. Thanks!

  2. Anonymous

    Hey,

    not sure this is a duplicate, but I think it is. Here is my trace:

    *** -[NSCFSet removeObject:]: attempt to remove nil
    
    	_NSSetRaiseRemoveNilException (in Foundation) + 80
    	-[NSCFSet removeObject:] (in Foundation) + 170
    	-[HgDir updateStatusFromOutput:] (in Murky) + 723
    	-[HgRevision updateStatus:error:] (in Murky) + 452
    	-[HgUncommittedRevision updateStatus:error:] (in Murky) + 55
    	-[HgRevision root] (in Murky) + 96
    	-[HgUncommittedRevision updatePaths:error:] (in Murky) + 42
    	-[HgRepository _checkWorkingTree:] (in Murky) + 67
    	-[HgRepository _checkRevisions] (in Murky) + 1154
    	-[HgRepository revisions] (in Murky) + 76
    	-[NSObject(NSKeyValueCoding) valueForKey:] (in Foundation) + 250
    	-[NSObject(NSKeyValueCoding) valueForKeyPath:] (in Foundation) + 474
    

    My repo is on a SMB-share, perhaps this is why it doesn't work? Local repositories work perfectly.

    Please let me know if you need something else.

    Peter

  3. Anonymous

    Here is the log you requested:

    15:07:52.850| Logging mode 3 enabled in domains: {HgLog, HgRepository}
    15:07:52.904| PYTHONPATH = ''
    15:07:52.950| 'hg' path = '/usr/local/bin/hg'
    15:08:07.362| Opened HgRepository[/Volumes/Drobo/hg/]
    2009-07-14 15:08:07.373 Murky[6957:10b] Could not find image named 'IBToolbarImageItemTemplate'.
    15:08:08.870| HgRepository: Tip changed from -1 to 0 ... updating revisions
    15:08:09.824| HgLog: Parsing...
    15:08:09.875| HgLog: took 0.1 sec to parse 1 revs
    2009-07-14 15:09:29.181 Murky[6957:10b] *** -[NSCFSet removeObject:]: attempt to remove nil
    

    hth

  4. Jens Alfke repo owner

    derpepe -- no, I don't think what you're reporting is the same bug. The exception name and backtrace are quite different. Could you file a new bug report, please? (Actually, could you first update to the latest Murky revision from yesterday, and try to reproduce it? I know I fixed a nasty problem with a virgin repository, which is what it looks like you have (tip=0).)

  5. Log in to comment