Issues

Issue #10 resolved

Cant install with Python 2.7

Artem Golub
created an issue

I keep getting this error when running python2 setup.py install,

RefactoringTool: build/py2k/guess_language/data/models/ve.py
RefactoringTool: build/py2k/guess_language/data/models/vi.py
RefactoringTool: build/py2k/guess_language/data/models/xh.py
RefactoringTool: build/py2k/guess_language/data/models/zu.py
RefactoringTool: build/py2k/test.py
RefactoringTool: Warnings/messages while refactoring:
RefactoringTool: ### In file build/py2k/generate_data.py ###
RefactoringTool: Line 68: 
formatting is only supported in Python 2.6 and above.
RefactoringTool: ### In file build/py2k/guess_language/__init__.py ###
RefactoringTool: Line 320: Removing function annotations completely.
running install
running bdist_egg
error: 'egg_base' must be a directory name (got `build/py2k/`)

Also, when I try to install using pip, I get this error.

root@Md:~# sudo pip install guess_language-spirit
Downloading/unpacking guess-language-spirit
  Could not find any downloads that satisfy the requirement guess-language-spirit
  Some externally hosted files were ignored (use --allow-external guess-language-spirit to allow).
Cleaning up...
No distributions at all found for guess-language-spirit
Storing debug log for failure in /root/.pip/pip.log

Comments (3)

  1. spirit repo owner

    Are you sure you have Python 2.7? This message seems to indicate otherwise:

    formatting is only supported in Python 2.6 and above.
    

    Also, I uploaded the source distribution to PyPI. pip install should work now, but please use the --pre option, as this package is in alpha state:

    pip install --pre guess_language-spirit

    I’ve tested installation with Python 2.7 and 3.4 and it should be OK.

  2. Log in to comment