Commits

Rick Testore committed ea7aa5d

solves issue #53: 1.4.3 Compatibility - sets JQuery min required version = 1.4.4

Comments (0)

Files changed (4)

 -----------------------------------
 
 - `Django <http://www.djangoproject.com/>`_ >= 1.2
-- `jQuery <http://jquery.com/>`_ >= 1.4.3
+- `jQuery <http://jquery.com/>`_ >= 1.4.4
 - `jQuery UI <http://jqueryui.com/>`_ >= 1.8
 
 Optional (but recommended)
 The jQuery and jQuery UI libraries are not included in the distribution but must be included
 in your templates. See the example project for an example using these libraries from the
 `Google CDN <http://code.google.com/apis/libraries/devguide.html#jquery>`_. Django-Selectable
-should work with `jQuery <http://jquery.com/>`_ >= 1.4.3 and `jQuery UI <http://jqueryui.com/>`_ >= 1.8
+should work with `jQuery <http://jquery.com/>`_ >= 1.4.4 and `jQuery UI <http://jqueryui.com/>`_ >= 1.8
 
     .. literalinclude:: ../example/core/templates/base.html
         :start-after: {% block extra-css %}{% endblock %}

selectable/static/selectable/js/jquery.dj.selectable.js

  * Docs: http://django-selectable.readthedocs.org/
  *
  * Depends:
- *   - jQuery 1.4.3+
+ *   - jQuery 1.4.4+
  *   - jQuery UI 1.8 widget factory
  *
  * Copyright 2010-2012, Mark Lavin

selectable/templatetags/jquery_libraries.py

     try:
         jquery_url = settings.JQUERY_URL
     except:
-        jquery_url = '//ajax.googleapis.com/ajax/libs/jquery/1.4.3/jquery.min.js'
+        jquery_url = '//ajax.googleapis.com/ajax/libs/jquery/1.4.4/jquery.min.js'
 
     try:
         jquery_ui_url = settings.JQUERY_UI_URL