Commits

Anonymous committed 593ffae

[1.2.X] Use Sphinx `:download:` directives for spatial database template creation scripts instead of linking to geodjango.org.

Backport of r15854 from trunk.

Comments (0)

Files changed (1)

docs/ref/contrib/gis/install.txt

 These commands may be placed in a shell script for later use; for convenience
 the following scripts are available:
 
-===============  ==========================================
-PostGIS Version  Shell Script
-===============  ==========================================
-1.3              `create_template_postgis-1.3.sh`_
-1.4              `create_template_postgis-1.4.sh`_
-1.5              `create_template_postgis-1.5.sh`_
-Debian/Ubuntu    `create_template_postgis-debian.sh`_
-===============  ==========================================
+===============  =============================================
+PostGIS Version  Bash Shell Script
+===============  =============================================
+1.3              :download:`create_template_postgis-1.3.sh`
+1.4              :download:`create_template_postgis-1.4.sh`
+1.5              :download:`create_template_postgis-1.5.sh`
+Debian/Ubuntu    :download:`create_template_postgis-debian.sh`
+===============  =============================================
 
 Afterwards, you may create a spatial database by simply specifying
 ``template_postgis`` as the template to use (via the ``-T`` option)::
 
         $ createuser --createdb <user>
 
-.. _create_template_postgis-1.3.sh: http://geodjango.org/docs/create_template_postgis-1.3.sh
-.. _create_template_postgis-1.4.sh: http://geodjango.org/docs/create_template_postgis-1.4.sh
-.. _create_template_postgis-1.5.sh: http://geodjango.org/docs/create_template_postgis-1.5.sh
-.. _create_template_postgis-debian.sh: http://geodjango.org/docs/create_template_postgis-debian.sh
-
 .. _create_spatialite_db:
 
 Creating a Spatial Database for SpatiaLite
     The PostGIS SQL files are not placed the PostgreSQL share directory in the
     Debian and Ubuntu packages, and are located instead special directory
     depending on the release.  Thus, when :ref:`spatialdb_template` use the 
-    `create_template_postgis-debian.sh`_ script instead 
+    :download:`create_template_postgis-debian.sh` script instead 
 
 .. _ubuntu:
 
 
   If not running PostgreSQL 8.3, then  replace ``8.3`` in the command above with the correct version.
 
-* Or use the `create_template_postgis-debian.sh`_ to create the spatial database.
+* Or use the :download:`create_template_postgis-debian.sh` to create the spatial database.
 
 .. _windows: