Commits

qyz  committed 07d6893

Fix pkt-line.h to compile with a non-GCC compiler

pkt-line.h uses GCC's __attribute__ extension but does not include
git-compat-util.h. So it will not compile with a compiler that does
not support this extension.

Signed-off-by: Junio C Hamano <junkio@cox.net>

  • Participants
  • Parent commits e898081

Comments (0)

Files changed (1)

 #ifndef PKTLINE_H
 #define PKTLINE_H
 
+#include "git-compat-util.h"
+
 /*
  * Silly packetized line writing interface
  */