Junio C Hamano  committed 80e0c0a

Work around an RPM build problem.

The require statement at the top of git-svnimport seems to confuse
rpmbuild dependency generation. It uses the newer notation "v5.8.0",
and rpm ends up requiring "perl(v5.8.0)", while we would want it to
say something like "perl >= 0:5.008".

Ryan suggests old-style "require 5.008" might fix this problem, so
here it is.

Signed-off-by: Junio C Hamano <>

  • Participants
  • Parent commits 64b1f6e
  • Branches master

Comments (0)

Files changed (1)

File git-svnimport.perl

 # The head revision is on branch "origin" by default.
 # You can change that with the '-o' option.
-require v5.8.0; # for shell-safe open("-|",LIST)
+require 5.008; # for shell-safe open("-|",LIST)
 use strict;
 use warnings;
 use Getopt::Std;