Issues

Issue #31 new

add easy_install to the 2.8 stdlib

Kristján Valur Jónsson
created an issue

One of the most annoying parts of any stackless installation is to have to manually go and fetch an easy_install thing, which is then used to bootstrap setuptools. This should really come out of the box....

Comments (5)

  1. Anonymous

    how is that different from CPython? Does python 3.X have that, or is that a new convenience hack?

    If so, then we should maybe just note the currently published two lines to type for cut and paste.

  2. Kristján Valur Jónsson reporter

    with python 2.7, if you install it, you still have to download and install easy_install, before you can start to use pip install. So, getting a functional python environment (one that has pip install) is currently a two-step process. I propose making 2.8 come with easy_install per default. I think that's how it works for 3.x, they already have "packaging" as a module.

  3. Anonymous

    ok, then that's a good thing without doubt.

    Before adding anything, I need to fix the 2.8 name, etc. How do we do changes: Simple check-ins, or mini-branches, or prepare everything in extra repos?

  4. rmtew

    3.4.0 bundles pip, wouldn't we do that as well, as a back port?

    And how are we affected by the pip repository? If there are modules for 2.8, will they host them?

  5. Anonymous

    rmtew yes, I think so.

    About PyPI: Not sure what problem you mean. If they would allow versions of modules which are 2.8 versions, but already exist as other versions? I think that depends on the individual package owners. But we always have the chance to use a different package name.

    We also could make a bundle, like "stackless-batteries", which pulls a bunch of packages in, from PyPI or somewhere else.

  6. Log in to comment