Issue #2 new

Fail to detect clang version when clang is cc

arrowdodger
created an issue

I'm using 9-STABLE and WITH_CLANG_IS_CC=yes.

During configure i'm getting: {{{ checking for a supported version of gcc... no (20120503) configure: error: please use gcc >= 3.0 or clang >= 2.9 }}}

In ./configure there are lines {{{ if test "x${CC} --version | head -n 1 | $SED 's/\(clang\) version.*/\1/'" = "xclang" ; then is_clang="clang" fi }}} On my system the test string becomes "xFreeBSD clang" and output of cc --version is {{{ FreeBSD clang version 3.1 (branches/release_31 155985) 20120503 Target: x86_64-unknown-freebsd9.0 Thread model: posix }}}

I'm not skilled with shell-foo, so i can't fix it myself.