Source

noirchat / INSTALL.rst

Installing NoirChat

Dependencies

To run NoirChat you need to install the following packages.

  1. libevent
  2. greenlet
  3. argparse
  4. gevent
  5. zope.interface

To test or develop NoirChat you should install

  1. unittest2
  2. mock

setup, build, install

Each of the above dependencies can be found in deps/ directory included with NoirChat's source.

Installation of each package should look like:

$ tar -zxvf greenlet-0.x.tar.gz $ cd greenlet-0.x $ python setup.py build $ sudo python setup.py install