1. Erik Southworth
  2. Steam Boiler
  3. Issues
Issue #2 resolved

Ubuntu Installation Successful But Receiving Illegal Options POSIX

Anonymous created an issue

I installed Steam-Boiler successfully on my Ubuntu 10.04 server using the default options, and I believe I have all of the prerequisites configured and installed. The configure script said everything was OK.

I'm receiving the following error when trying to install the counter-strike source server files:

user@user:/games/steam/css$ steam -command update -game 'counter-strike source' set: 28: Illegal option -o posix

Anyone know what's going on? All help is appreciated. Thanks!

Comments (4)

  1. Erk OwN

    So I read the other issue that was posted, and I followed your suggestion of:

    "You can try to comment line 28 out or set line 1 to !#/bin/bash. Let me know what shell you are using with boiler. Also, the distro, Ubuntu, Fedora"

    Changing line 1 to !#/bin/bash produced an error. I commented line 28 out, and everything appears to be working at the moment. What's the setting used for?

    I run ubuntu 10.04 (ylmf os v 3.0). I thought I ran the default bash shell... how do I find out what I'm running?

  2. Log in to comment