Commits

Matthew Turland committed ddadb22

Fixed test_system_views not checking for MySQL >= 5.0.0 as information_schema support is not available in previous versions

Comments (0)

Files changed (1)

test/dialect/test_mysql.py

             }
         )
 
-    @testing.only_on(['mysql'],
-                    'requires information_schema')
+    @testing.only_on(['mysql'], 'requires information_schema')
+    @testing.exclude('mysql', '<', (5, 0, 0), 'no information_schema support')
     def test_system_views(self):
         dialect = testing.db.dialect
         connection = testing.db.connect()