Commits

Gustavo Picon  committed f0a1927

treebeard needs django 1.3+

  • Participants
  • Parent commits 4eb1e3e

Comments (0)

Files changed (2)

     package_dir={'treebeard': 'treebeard'},
     package_data={
         'treebeard': ['templates/admin/*.html', 'static/treebeard/*']},
-    description='Efficient tree implementations for Django 1.2+',
+    description='Efficient tree implementations for Django 1.3+',
     long_description=open(root_dir() + '/README').read(),
     cmdclass={'test': pytest_test},
-    install_requires=['Django>=1.2'],
+    install_requires=['Django>=1.3'],
     tests_require=['pytest'],
     classifiers=[
         'Development Status :: 5 - Production/Stable',

File treebeard/forms.py

             else:
                 self.instance = self.Meta.model.add_root(**cl_data)
         else:
-            # this is needed in django >= 1.2
             self.instance.save()
             if reference_node_id:
                 reference_node = self.Meta.model.objects.get(