Source

distribute / setuptools / dist.py

The branch 'default' does not exist.
Author Commit Message Labels Comments Date
Jason R. Coombs
Merge
Erik Bray
Fixes and adds a regression test for #323; required adding some new keyword arguments to existing pkg_resources methods. Also had to update how __path__ is handled for namespace packages to ensure that when a new egg distribution containing a namespace package is placed on sys.path, the entries in __path__ are in the same order they would have been in had that egg been on the path when pkg_resources was first imported
Jason R. Coombs
Added comment and updated CHANGES
g2p
Don't wrap sys.stdout if it's in the correct encoding already.
Stefan H. Holek
Print metadata in UTF-8 independent of platform. Fixes #311.
Comments 1
Erik Bray
Adds a fix for issue #318, including a regression test. This also fixes another test that was passing trivially due to *bug* in yet another test, ugh
Jason R. Coombs
Backout changes to dist.py from 488cc8a13f66
Branches
fix-issue-227
Erik Bray
First stab at a fix. The hack that allows it to work is that it allows the easy_install command to take a '-' argument which simply means 'don't run', so that arguments can be passed to the easy_install command from the comannd line without running it.
Branches
fix-issue-227
Erik Bray
setting to_scan to [] instead of None ensures (somewhat confusingly) that find_links are used, when available, to install each dist listed in setup_requires
Branches
sandbox-issue
tarek
backporting the API Eby added in 0.6c11
Branches
0.6-maintenance
Lennart Regebro
Name changes of the parameters.
Branches
0.6-maintenance
Martin von Löwis
Support attrs is None.
Branches
0.6-maintenance
Martin von Löwis
Deal with convert_doctests_2to3 not being set.
Branches
0.6-maintenance
Martin von Löwis
Fix processing of convert_doctests_2to3.
Branches
0.6-maintenance
Martin von Löwis
Add default for pop.
Branches
0.6-maintenance
Martin von Löwis
Add src_root attribute to support installing from a copy.
Branches
0.6-maintenance
agronholm
Fix deprecation warnings (change <> to !=)
phillip.eby
Added a warning if a namespace package is declared, but its parent
Branches
setuptools-0.6
phillip.eby
Backport all known 2.5-compatibility fixes
Branches
setuptools-0.6
phillip.eby
* Fixed ``AttributeError`` when trying to download a ``setup_requires``
Branches
setuptools-0.6
phillip.eby
Backport 'module' fixes to 0.6
Branches
setuptools-0.6
phillip.eby
Creating a branch for the "stable" 0.6 development line of setuptools,
Branches
setuptools-0.6