Issue #137 new

Upgrade of docutils causes

Jeroen Ruigrok van der Werven
created an issue

An upgrade of docutils causes the roman.py module to not be installed.

{{{ $ easy_install docutils==0.5 }}}

[snip install details]

{{{ $ easy_install -U docutils Searching for docutils Reading http://pypi.python.org/simple/docutils/ Reading http://docutils.sourceforge.net/ Best match: docutils 0.6 Downloading http://prdownloads.sourceforge.net/docutils/docutils-0.6.tar.gz?download Processing docutils-0.6.tar.gz Running docutils-0.6/setup.py -q bdist_egg --dist-dir /tmp/easy_install-BErDRq/docutils-0.6/egg-dist-tmp-ruvo6C "roman" module already present; ignoring extras/roman.py. zip_safe flag not set; analyzing archive contents... }}}

So you can see that it detects the roman.py of the old install and subsequently won't install it for the newer version. setup.py's get_extras() is probably at fault here by testing against the installed version.