Issue #181 resolved

Problem with dependency resolution

Nikolaus Rath
created an issue

distribute seems to have trouble recognizing installed versions of packages when resolving dependencies.

The following example can be reproduced with the Ubuntu karmic live cd.

  1. Install python-pycryptopp and python-distribute
  2. Extract the attached sample project
  3. Run python setup.py install

Even though pycryptopp 0.5.17 is locally installed, distribute attempts to download it. However, it does not download the most recent version (0.5.19), but for some reason tries to download exactly the installed version:

{{{ [...] Processing dependencies for s3ql==0.0.0 Searching for pycryptopp==0.5.17 Reading http://pypi.python.org/simple/pycryptopp/ Reading http://allmydata.org/trac/pycryptopp Reading http://allmydata.org/source/pycryptopp Reading http://allmydata.org/source/zfec Best match: pycryptopp 0.5.17 Downloading http://pypi.python.org/packages/source/p/pycryptopp/pycryptopp-0.5.17.tar.gz#md5=b3d19e7203531f8bd241ae58062f99e4 Processing pycryptopp-0.5.17.tar.gz [...] }}}

Comments (4)

  1. Zooko O'Whielacronx

    This could be the same as #142. Could you verify whether the fix from #142 fixes it? Also, maybe we should ask the Ubuntu folks to backport the fix, but if so we should try it with Lucid rather than Karmic as Lucid is an Ubuntu Long-Term-Support release.

  2. Nikolaus Rath reporter

    Can you give me more detailed instructions on how to apply the fix? Can I just change the "use_setuptools(version='0.6')" line in setup.py to some newer version that contains the fix? Thanks!

  3. Log in to comment