easy_install script references wrong version after upgrade (Ubuntu)
easy_install fails due to
__requires__ = 'distribute==0.6.10' # ... load_entry_point('distribute==0.6.10', 'console_scripts', 'easy_install')()
when I do a `pip install` python modules that require more recent versions of distribute, like `URLObject`, on an Ubuntu 10.04 server with an old version of pip (including easy_install)
Interestingly Ubuntu 12.04 easy_install continues to require a particular version of distribute (but not its other dependencies).
__requires__ = 'distribute==0.6.24dev-r0'
Why not `>` rather than `==` for all dependencies (including `distribute`) in easy_install? Isn't `distribute` always reverse compatible?