Issue #53 invalid

Error when running easy_install -U distribute under Python 3.1

Lennart Regebro
created an issue

As we now have the ability to not only install distribute under Python3, but with the 0.6.3 release, also upgrade it, a new bug has of course popped up. ;-)

The install runs fine, and does install the new version, but there is an error at the end of the process:

{{{ Error in atexit._run_exitfuncs: TypeError: print_exception(): Exception expected for value, str found }}}

I tried to find where this _run_exitfuncs exists, but I can't find it, so I have no idea where to even start. But since the install actually works, this is a minor issue.

Comments (5)

  1. Tarek Ziadé repo owner

    _run_exitfuncs is the function called in the atexit module (a c module in Python 3) that will run all functions previously registered by atexit.register, when the program quits.

    Distribute doesn't register anything in the atexit registery.

    Unfortunately, as far as i understand, atexit doesn't provide a Python API or any other interface to list all the registered functions, but this is something we could add in Modules/atexitmodule.c in order to debug this problem.

  2. Thijs Triemstra
    • changed milestone to 0.6.7

    This can probably be closed as I can't reproduce it with 0.6.6 either:

    $ easy_install-3.1 -U distribute
    Searching for distribute
    Reading http://pypi.python.org/simple/distribute/
    Best match: distribute 0.6.6
    Processing distribute-0.6.6-py3.1.egg
    distribute 0.6.6 is already the active version in easy-install.pth
    Installing easy_install script to /usr/local/bin
    Installing easy_install-3.1 script to /usr/local/bin
    
    Using /usr/local/lib/python3.1/site-packages/distribute-0.6.6-py3.1.egg
    Processing dependencies for distribute
    Finished processing dependencies for distribute
    
  3. Log in to comment