Issue #110 resolved

An error with the file parsing for which package is the source archive.

Anonymous created an issue

Hi,

trying to use netCDF4 in buildout I get this error on my ubuntu machine (python2.6):

Getting distribution for 'netCDF4'. Error: Couldn't install: netCDF4 0.8.2.macosx-10.5-ppc

I think because easy_install is getting the wrong file from here: http://code.google.com/p/netcdf4-python/downloads/list

It is mistaking the ppc binary for macosx as the source file. so I'd like to tell it to use: http://netcdf4-python.googlecode.com/files/netCDF4-0.8.2.tar.gz

Note the ppc macosx file name: 'http://netcdf4-python.googlecode.com/files/netCDF4-0.8.2.macosx-10.5-ppc.tar.gz' is the one that's being mistaken for. It should be getting 'http://netcdf4-python.googlecode.com/files/netCDF4-0.8.2.tar.gz' instead.

It seems to be an error with the file parsing for which package is the source archive.

-- Rene Dudfield.

Comments (3)

  1. Noufal Ibrahim

    Are you seeing this only from within buildout? Also, can you provide the architecture of the machine you're trying this on? I ask because on a x86 laptop running Ubuntu (Python2.6), it works for me when I try to install from outside.

  2. Log in to comment