1. Tarek Ziadé
  2. distribute
Issue #165 new

SQL Alchemy installation fails

Anonymous created an issue

I logged the bug with the SQL Alchemy team and they suggested that I report a bug with you as well.

I'm trying to install SQL Alchemy 0.6.0 on both python version 2.6.5 and 3.1.2. I run distribute_setup.py without issue but when I try to run setup.py, I get the following message:

running install running bdist_egg error: error in 'egg_base' option: 'lib' does not exist or is not a directory.

My OS is Windows Vista.

Comments (3)

  1. Anonymous

    I had the same error in both. I included the entire error message for setup.py. When I ran distribute_setup there was a lot of text but I didn't read any warnings.

    On a possibly related note, I get the following error when I try to install pg8000:

    running build running build_py error: package directory 'pg8000' does not exist

  2. Tarek Ziadé repo owner

    Your distribute installation seems fine.

    I have the feeling that something is wrong with your environment, rather. Check that you don't have a distutils.cfg in your HOME dir, or a .pydistutils.cfg, and let me see your sys.path please.

    Also, to check if the problem is on distribute side or not, you can install virtualenv and try the following :

    $ virtualenv --no-site-packages /some/temp/dir
    $ cd /some/temp/dir
    $ bin/easy_install SQLAlchemy
    

    if it works try this, to see if its a problem in your setup:

    $ virtualenv --distribute --no-site-packages /some/temp/dir
    $ cd /some/temp/dir
    $ bin/easy_install SQLAlchemy
    
  3. Log in to comment