1. Tarek Ziadé
  2. distribute
Issue #359 new

pkg_resources.VersionConflict should report which package has the requirement

Brent Tubbs
created an issue

When I see a traceback like this:

Traceback (most recent call last):
  File "/app/.heroku/venv/bin/vr_beat", line 8, in <module>
    from pkg_resources import load_entry_point
  File "/app/.heroku/venv/lib/python2.7/site-packages/distribute-0.6.31-py2.7.egg/pkg_resources.py", line 2833, in <module>
    parse_requirements(__requires__), Environment()
  File "/app/.heroku/venv/lib/python2.7/site-packages/distribute-0.6.31-py2.7.egg/pkg_resources.py", line 608, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (python-dateutil 2.1 (/app/.heroku/venv/lib/python2.7/site-packages), Requirement.parse('python-dateutil>=1.5,<2.0'))

It would be really nice if it told me which package has the offending requirement. Otherwise it can be very time consuming to manually root through the dependency tree to find it.

Comments (0)

  1. Log in to comment