setuptools.command.easy_install doesn't exist

Create issue
Issue #66 resolved
Former user created an issue

In a buildout with an lxml section which uses z3c.recipe.staticlxml, i get: "ImportError: No module named setuptools.command.easy_install"

I was able to work around it by creating a virtualenv without Distribute, installing the old setuptools in there, and using this Python version to do the buildout.

Perhaps the recipe zc.recipe.staticlxml is wrong here, but as Distribute is going to be a drop-in replacement for distutils, i thought this might be a bug.

Apart from this, Distribute works like a charm for me!


setuptools.dist <module 'setuptools.dist' from '/usr/local/lib/python2.6/dist-packages/distribute-0.6.3-py2.6.egg/setuptools/dist.pyc'>; }}}

Comments (12)

  1. Tarek Ziadé repo owner
    • changed status to open

    Thanks for the feedback,

    would you mind trying with the latest to see if it works ?

    this will pick the current 0.6.5 dev version, where Reinout and I have fixed bugs related to buildout support.


  2. Former user Account Deleted reporter

    How is this supposed to work?

    I did wget in my buildout dir, and ran

    $ python2.4 
    An internal error occured due to a bug in either zc.buildout or in a
    recipe being used:
    Traceback (most recent call last):
      File "/tmp/tmpnhqyVr/zc.buildout-1.4.1-py2.4.egg/zc/buildout/", line 1659, in main
        getattr(buildout, command)(args)
      File "/tmp/tmpnhqyVr/zc.buildout-1.4.1-py2.4.egg/zc/buildout/", line 363, in bootstrap
      File "/usr/lib/python2.4/site-packages/distribute-0.6.4-py2.4.egg/", line 621, in require
        needed = self.resolve(parse_requirements(requirements))
      File "/usr/lib/python2.4/site-packages/distribute-0.6.4-py2.4.egg/", line 519, in resolve
        raise DistributionNotFound(req)  # XXX put more info here
    DistributionNotFound: setuptools
  3. Former user Account Deleted reporter

    That worked. Thanks Tarek!

    # untar and install
    # cd to buildout dir
    ./bin buildout
  4. Mikko Ohtamaa
    • changed status to open
    • changed version to 0.6.14

    This happens with buildout, Python 2.6 shipped with OSX and Distribute 0.6.14

    Getting distribution for 'zc.recipe.egg'.
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
    ImportError: No module named setuptools.command.easy_install
    An error occurred when trying to install zc.recipe.egg 1.3.2. Look above this message for any errors that were output by easy_install.

    Looks like there is no such module:

    python -c "import setuptools.commands"
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
    ImportError: No module named commands

    I already tried to use manual Distribute installation method, but no luck.


    >>> import setuptools
    >>> setuptools.__file__
  5. Mikko Ohtamaa

    Also confirmed that after switching to Macports Python the issue went away.

    Must be something fishy with OSX Python installation?

  6. Log in to comment