1. Tarek Ziadé
  2. distribute
Issue #80 resolved

test_develop fails with Python 3.1

Arfrever Frehtes Taifersar Arahesis
created an issue

In Distribute 0.6.7 test_develop fails with Python 3.1. I'm attaching the output of tests. (All tests pass with Python 2.5 and 2.6.)

Comments (4)

  1. Arfrever Frehtes Taifersar Arahesis reporter
    • changed status to open

    The import in setuptools/command/init.py breaks build of Mayavi 3.3.0, whose setup.py contains:

    from setuptools.command import develop, install_scripts ... class MyInstallScripts(install_scripts.install_scripts): ...

    And the fix for this issue causes:

    Traceback (most recent call last): File "setup.py", line 337, in <module> class MyInstallScripts(install_scripts.install_scripts): AttributeError: class install_scripts has no attribute 'install_scripts'

    I suggest to change the following line in setuptools/command/init.py: from setuptools.command.install_scripts import install_scripts ... to ... from setuptools.command import install_scripts

  2. Log in to comment