Commits

anatoly techtonik committed 57e019d

add patch for Trac 0.12.2 to get rid of setuptools dependency when building
default environment

  • Participants
  • Parent commits a360e7e

Comments (0)

Files changed (1)

File trac-0.12.2.patch

+Index: trac/web/__init__.py
+===================================================================
+--- trac/web/__init__.py	(revision 10832)
++++ trac/web/__init__.py	(working copy)
+@@ -3,21 +3,5 @@
+ import mimetypes
+ mimetypes.init()
+ 
+-# With mod_python we'll have to delay importing trac.web.api until
+-# modpython_frontend.handler() has been called since the
+-# PYTHON_EGG_CACHE variable is set from there
+-#
+-# TODO: Remove this once the Genshi zip_safe issue has been resolved.
+ 
+-import os
+-from pkg_resources import get_distribution
+-if not os.path.isdir(get_distribution('genshi').location):
+-    try:
+-        import mod_python.apache
+-        import sys
+-        if 'trac.web.modpython_frontend' in sys.modules:
+-            from trac.web.api import *
+-    except ImportError:
+-        from trac.web.api import *
+-else:
+-    from trac.web.api import *
++from trac.web.api import *
+Index: trac/admin/console.py
+===================================================================
+--- trac/admin/console.py	(revision 10832)
++++ trac/admin/console.py	(working copy)
+@@ -35,7 +35,7 @@
+ from trac.wiki.admin import WikiAdmin
+ from trac.wiki.macros import WikiMacroBase
+ 
+-TRAC_VERSION = pkg_resources.get_distribution('Trac').version
++TRAC_VERSION = VERSION
+ rl_completion_suppress_append = None
+ LANG = os.environ.get('LANG')
+