1. Timo Haberkern
  2. Server2Go
Issue #60 new

server2go.exe and apache.exe does not shut down while using Firefox portable

Anonymous created an issue

server2go.exe and apache.exe does not shut down while using Firefox portable

Comments (12)

  1. Anonymous

    I found a way to get around this when using a browser other than the default:

    I simply make a call via ajax to a PHP function which contains the following code:

    <?php
    shell_exec('taskkill /T /F /IM "Server2Go.exe"');
    ?>
    

    This ends the task tree for Server2Go which kills the Server2Go.exe file, Apache and MySql. Unfortunately it still doesn't run any of the exe files you have listed in the pms_config.ini file to run after shutdown, but at least it kills all the necessary processes.

    Hope this helps someone!

  2. Anonymous

    Wow!

    What a bright idea! :-)

    I take it that you added this to the section of which programs to run on "shut down" in that same config file?

    Now does this kill just the single process, or the whole process tree?

    - Jim

  3. Anonymous

    I actually just do this from within my web app from an AJAX call so it happens behind the scenes. Unfortunately Server2Go doesn't run any of the EXEs listed in the shut down config when using this method, but at least it does shut down! :)

    And this does shut down the entire process tree so Server2Go, Apache and MySQL are all shut down...

    Thanks! :)

  4. Anonymous

    if I change firefox.exe to ffp.exe - it doesn't launch, I get an error that firefox.exe doesn't exist. Is this a known issue?

    I changed it back to firefox.exe in the .ini file - it now works, but doesn't shutdown when I close the browser. Are there any others who've had any further issie with using Portable Firfox?

    THanks!

  5. Benjamin Favre

    Working solution to use googlechrome portable with server2go and detect shutdown !!

    Basically you follow the instruction for getting Firefox portable to work and do the same for chrome. You rename chrome.exe (path : App\Chrome-bin\chrome.exe) to ffp.exe

    pms_config.ini file :

    BrowserType=PORTABLEFIREFOX BrowserPath=browser/GoogleChromePortable/GoogleChromePortable.EXE

    Here is my GoogleChromePortable.ini file :

    [GoogleChromePortable] Google ChromeDirectory=..\GoogleChromePortable\App\Chrome-bin ProfileDirectory=..\GoogleChromePortable\Data\profile SettingsDirectory=..\GoogleChromePortable\Data\settings AdditionalParameters=--app=http://127.0.0.1:4001 PluginsDirectory=Data\plugins Google ChromeExecutable=ffp.EXE AllowMultipleInstances=true DisableIntelligentStart=false SkipChromeFix=false SkipCompregFix=false RunLocally=true

    In "AdditionalParameters" i use -app to start chrome in application mode.

    Good luck.

  6. Terry Woody

    Thank you @ Benjamin Favre! Works great, but for life of me cannot get server2go to shutdown. Tried all kinds of combinations on the pms_config file with no luck...

    Hope this thread is still active enough:

    <?php
    shell_exec('taskkill /T /F /IM "Server2Go.exe"');
    ?>
    

    Anyone give me pointer on how to call the above PHP with ajax to force shutdown?

    Many thanks in advance.

  7. Mélissa R

    Hi. I'm having the same issue that i can't resolve... I try Banjamin Favre's solution, that is EXACTLY what i want to do, but it doesn't work... :'(

    I've an alert box told me "can't find 'chrome.exe'" (because i renamed it "ffp.exe" as told Benjamin Favre)

    I try to put GoogleChromePortable.ini file in GoogleChromePortable folder, or in GoogleChromePortable/Other/Source/ , same issue...

    Is anybody knows how I can fix this? Thanks!

  8. Andreas Mueller

    Thanks for the taskkill workaround, that at least gets it to work. There is problem though with that: if I start server2go from a cdrom and use that taskkill hack, something still locks the cd-tray. Only brute force with a wire or pc restart will free the tray.

    I've checked for possible filelocks, but there ar none, and I haven't been able to identify the culprit.

  9. Log in to comment