Source

moin-2.0 / setup.py

Author Commit Message Labels Comments Date
Thomas Waldmann
require emeraldtree 0.9.2, fixes #192
Reimar Bauer
setup: require pytest-pep8<1.0.3 because pytest-pep8 1.0.3 requires pytest 2.3 and our test code needs to be refactored for pytest 2.3
Reimar Bauer
setup: new version of XStatic-svg-edit-moin, fixes #149 by the patch of Sam Toyer in the save extension
Thomas Waldmann
require pytest < 2.3, because pytest 2.3.x doesn't work with our test code, likely due to the fixture changes done after 2.2
Roger Haase
CSS and javascript changes to support obsolete IE7 and IE8 browsers,
Thomas Waldmann
add markdown converter, thanks to Andreas Kloeckner
Thomas Waldmann
fix message extraction configuration in setup.py
Thomas Waldmann
implement i18n for .js by using jinja2 js templates
Thomas Waldmann
merged
Roger Haase
remove multiDownload jquery plugin
Thomas Waldmann
implemented mongodb store, add pymongo to setup.py
Thomas Waldmann
make file ends pep8 compliant (== exactly 1 LF at EOF)
Thomas Waldmann
fix some pep8 issues, remove the fixed files from pep8 checker's exlusion list
Thomas Waldmann
remove test_sourcecode, replace it by pytest-pep8
Thomas Waldmann
require pep8 in setup.py, import pep8 from sys.path (not from .)
Thomas Waldmann
use polyglot writer, require emeraldtree >= 0.9.1
Thomas Waldmann
setup.py: add missing import, use 2.4x branch of whoosh repo to get latest maintenance updates
Thomas Waldmann
setup.py: make sure it uses whoosh repo tip from our repo
Thomas Waldmann
for whoosh, use tip of tw's repo for better control / quicker fixes
Thomas Waldmann
setup.py: add foobar theme, cosmetic changes
Thomas Waldmann
setup.py: use Flask-Script>=0.3.3, it has the stuff we need in 0.3.3 (multi-thread/process server options)
Thomas Waldmann
use Flask-Script repo version 0.3.3dev, which has the --threaded and --processes N options for the builtin server
Thomas Waldmann
remove/comment some outdated stuff in setup.py
Thomas Waldmann
use a fixed flask-themes
Bruno Gola
fixes the data files installation
Thomas Waldmann
require whoosh>=2.3.1 and pull it from the repo (not on pypi yet)
Thomas Waldmann
require sphinx >= 1.1, it has the apidoc building script now
Thomas Waldmann
raise other requirements - later stuff, less bugs
Thomas Waldmann
raise Flask* requirements to latest releases
Thomas Waldmann
require werkzeug 0.8.1, fix tests, remove old werkzeug related workarounds and monkeypatch
  1. Prev
  2. 1
  3. 2
  4. 3
  5. 4
  6. Next