1. Thomas Waldmann
  2. moin-2.0
  3. Issues
Issue #116 invalid

py.test script raises ImportMismatchError

Anonymous created an issue

When attempting to run the MoinMoin test suite from the development environment, $ py.test fails with an ImportMismatchError. On the other hand, all the tests run correctly using $ py.test MoinMoin. Full traceback at paste.pocoo.org/show/v8CJQVJx3u5NCWy8O2AI/

Comments (3)

  1. Thomas Waldmann repo owner

    from #moin-dev:

    (13:02) <      qxcv> got a fix in #pylib - it works for me when I use "py.test MoinMoin" rather than just "py.test"
    (13:04) <    pkumar> well, as the error says it has some problem with conftest imports
    (13:04) <    pkumar> onein MoinMoin and another in biuld dir
    (13:05) <    pkumar> probably, specifying MoinMoin there tells where to get conftest specifically 
    (13:05) <    pkumar> in this case
    (13:05) <    pkumar> qxcv, ^
    (13:06) <    pkumar> cleaning up the build may help perhaps
    (13:06) <      qxcv> yes, specifiying MoinMoin or cd'ing into MoinMoin makes it work fine
    (13:08) <    pkumar> qxcv, just for a test, can you just try removing the build dir and running py.test . probably you can cut and paste your build dir somewhere else outside your moin repo.?
    (13:09) <      qxcv> test suite runs fine when I take out the build directory
    (13:10) <    pkumar> even without specifying MoinMoin explicitly?
    (13:10) <    pkumar> with just "py.test"?
    (13:10) <      qxcv> yes, just running py.test works when I move the build dir
    (13:14) < ThomasWal> why do you have that build dir btw?
    (13:14) <    pkumar> ok, not sure about different os and platform dependencies   but build  should get cleaned up at the end of quickinstall.
    (13:14) <      qxcv> probably because of playing around with make
    (13:15) <      qxcv> I'd say it's probably my fault :S
    (13:16) <    pkumar> it's good to play around with stuffs, I would say. 
    

    Setting the state to invalid because this is no moin bug. It is good to have the bug report here though, in case of other people get the same issue.

  2. Ashutosh Singla

    I faced the same problem yesterday, possibly due to the presence of build directory, after removing the build directory, the issue was solved, I confirmed that the build directory doesn't appear on installation. I tried but was not able to reproduce the problem.

  3. Log in to comment