Issue #201 resolved

use passlib?

Thomas Waldmann
repo owner created an issue

http://packages.python.org/passlib/

Found this while looking whether the md5crypt stuff is available via a pypi package (it's not). Maybe we could rather use passlib from pypi as a package than MoinMoin/util/md5crypt.py.

Comments (3)

  1. Thomas Waldmann reporter

    after a quick check: looks good, passlib itself is pure python code and support py2.5+ and py3. support strong pbkdf2 and sha512-crypt without additional requirements.

    (we could even consider using it in moin 1.9.x, as since 1.9.4 we already need 2.5 for the bundled werkzeug).

  2. Log in to comment