Bootstrap failed

Issue #193 closed
Cyril DUBUS
created an issue

Hi,

I cannot understand your build system. It is just not working at all for me :(

I get : "Failed bootstrapping Monit"

And there is nothing in "libmonit" folder.

I dont understand why, there is no error, nothing.

After the failed boostrap, I tried ./configure, and it worked like a charm, but when it comes to make, it goes directly into the libmonit folder and it crashes right away.

I tried with version 5.12.2, 5.13 and lastest

  • Debian 7
  • libtool (GNU libtool) 2.4.2
  • autoconf (GNU Autoconf) 2.69
  • automake (GNU automake) 1.11.6

I tried on several computers (each one was running Debian 7), exact same behavior

Any idea what's going on ? How can I see what's wrong with your bootstrap file ??

Thank you !

Comments (5)

  1. Tildeslash repo owner

    Monit is split into two separate components: monit + libmonit. You need to checkout both in order to build Monit:

    git clone git@bitbucket.org:tildeslash/monit.git --recursive
    

    If you have older git version, you may need to checkout libmonit into libmonit subdirectory separately.

  2. Cyril DUBUS reporter

    Thank you for your answer, the --recursive does not work on my installation, it says I have a permission issue with a public key.

    Cloning the libmonit into the monit folder did the trick.

  3. Log in to comment