work with somewhat older automake

Issue #413 closed
Ulrich Windl created an issue

After trying to fix a bug in the source, "make" requires automake-1.14, but my system (SLES11 SP4) only ships with automake-1.10. Replacing (entering the command by hand) the versioned aclocal and automake with the unversioned variants, I was able to build. Is it necessary to use versioned aclocal and automake, and is it necessary to have a more recent version than 1.10?

Comments (2)

  1. Tildeslash repo owner

    We don't require a special version of the build-tools. Any version requirements are by the tools themselves. If you look in the bootstrap script we have some recommendations regarding versions which we have found out works together. I'm currently using automake-1.15, but I recall building with 1.10 did work.

  2. Ulrich Windl reporter

    OK, I don't know why this popped up: At the time I had no autoconf and automake package installed, and after install I still saw the issue (specific version 1.14 being demanded). Maybe I should have reconfigured after that. Anyway an rpmbuild worked for the patched sources, so it should be OK to close this issue (unless you found an issue in the explanation above above).

  3. Log in to comment