Disk usage percentage

Issue #514 resolved
Georgiy Mozzhukhin created an issue

Suddenly, percentage of the disk usage started to show free space and not used space, as before. Not a critical for me, but start page of the app shows the used space. Is that a bug?

Tried: uninstall/install app, restart macOS, restart Notification Center. macOS Sierra 10.12.1.

Comments (6)

  1. Tildeslash repo owner

    This could happen at startup if disk data collection failed. If this happen, just close Notification Center for 30 seconds. The Monit Widget will then stop. No need to reinstall the widget. Then open Notification Center to start the Widget again. It is very unlikely that the same problem occurs again and disk reporting should be fine. I've also modified the code to make the disk reporting more failsafe in a future release.

  2. Georgiy Mozzhukhin reporter

    Thanks for the reply! Unfortunately, this isn't solved this problem. BUT, funny thing. This problem only occurs with 25/75% pair :D Either when I delete some files, or add some files, widget shows correct percentage (24% and 26% in my test cases), but not 25%

  3. Tildeslash repo owner

    That is funny! From the top of my head, I can't even imagine how this can happen. Could you check with the console /Applications/Utilities/Console.app and see if there are any error messages from Monit?

  4. Tildeslash repo owner

    The problem has been identified and reproduced. As you mentioned, the problem only occurs if your hard disk usage is exactly 25%. 75% was set as an initial value in the Disk UI Label and 25% in the disk-model. When Monit starts to gather disk data the 75% disk usage label will be updated to reflect real disk usage. However, since we cache data and only update the UI on change, the 75% label was not updated if disk usage was exactly 25%. The problem has been fixed by setting the initial disk usage percentage in the data-model to 0%.

    Apologises for the late reply, but I only saw this myself when I installed a new disk and was able to reproduce. This was a slightly intricate bug which has been fixed in the new 1.2 version of the Widget which currently is in AppReview and should hopefully be available shortly.

  5. Georgiy Mozzhukhin reporter

    Awesome, thanks! Additional thanks for the detailed answer, It's always nice to see origins of the bugs :)

  6. Log in to comment