Atomic breaks cross compiling on Linux

Issue #568 resolved
Alexander Dahl
created an issue

For release 5.21.0 commit 18cdea177f66403cf5510d022bd2b2e306445412 reactivates the autoconf check "for Atomic support". This breaks cross compiling on Linux with ptxdist for Linux with the following message:

checking for Atomic support... configure: error: in `/home/adahl/Work/bsp/***/build-target/monit-5.21.0/libmonit':
configure: error: cannot run test program while cross compiling
See `config.log' for more details
configure: error: ./configure failed for libmonit

This worked fine with 5.20.0.

Comments (4)

  1. Log in to comment