Monitoring the root file system for disk usage fails in 5.22

Issue #593 resolved
Jörg Ziegler
created an issue

I've had a monitrc line which worked fine on 5.19 to check the filling of a ramdisk, mounted as a root file system:

CHECK FILESYSTEM ramdisk PATH /
  IF SPACE USAGE > 90% THEN ALERT

Using 5.22 this fails, claiming the file system does not exist. Any hints on how to resolve this?

Comments (10)

  1. Tildeslash repo owner

    Please can you provide more details?:

    1.) which platform it is?

    2.) output of "mount"

    3.) monit 5.22.0 was not released yet ... is it really 5.22.0 (from development repository)?

  2. Jörg Ziegler reporter

    1) embedded/ARM

    2) output of mount is

    rootfs on / type rootfs (rw,size=235880k,nr_inodes=58970)
    proc on /proc type proc (rw,relatime)
    sysfs on /sys type sysfs (rw,relatime)
    debugfs on /sys/kernel/debug type debugfs (rw,relatime)
    devtmpfs on /dev type devtmpfs (rw,relatime,size=235880k,nr_inodes=58970,mode=755)
    tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
    tmpfs on /var/volatile type tmpfs (rw,relatime)
    /dev/mmcblk0p1 on /run/media/mmcblk0p1 type vfat (rw,relatime,fmask=0000,dmask=0000,allow_utime=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
    devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620)
    

    3) yes, it's 5.22 building from the tag release-5-22-0 - I stumbled about the git tag and assumed that it had been released...

  3. Tildeslash repo owner

    What platform it exactly is? (so we can reproduce)

    The 5.22.0 release is just pending, but not officially available yet - the release tag was added to the repository as part of the release work. Will remove the tag and include fix for this issue to the 5.22.0 release.

  4. Jörg Ziegler reporter

    fantastic, thanks for the instant response. It's a custom embedded platform built using petalinux, a yocto-like rootfs builder running on embedded/arm - not a standard distribution.

    here's the output of uname, if that helps. Busybox is used as the shell. Linux 4.4.0-xilinx-gdfb97bc #2 SMP PREEMPT Tue Apr 18 10:10:29 CEST 2017 armv7l GNU/Linux

    I can of course provide system outputs of dedicated commands (and I'd be happy to) - 100% reproducability is unlikely.

  5. Tildeslash repo owner

    Please can you test the development snapshot?

    I didn't find any pre-build image which would use rootfs as ramdisk directly ... tried various live distros + live Yocto image, all of them used an overlay mount for root filesystems (on top of rootfs), usually based on aufs.

    I thus wasn't able to verify the fix on identical setup, the problem should be fixed though, as the exception for rootfs is removed and monit will now scan the whole mounts table for overlay mounts.

  6. Jörg Ziegler reporter

    Ignore my previous edit - it's working! I had the monitrc still in a hacked state from my attempts yesterday. Thanks so much for the fix!

    Looking forward to the released version!

  7. Log in to comment