Commits

Patrick Mézard committed 22f348c

obsolete/evolve: fix grammar in prerequisite messages

  • Participants
  • Parent commits ea7f2a4

Comments (0)

Files changed (2)

     try:
         obsolete = extensions.find('obsolete')
     except KeyError:
-        raise error.Abort(_('evolution extension require obsolete extension.'))
+        raise error.Abort(_('evolution extension requires obsolete extension.'))
     try:
         rebase = extensions.find('rebase')
     except KeyError:
         rebase = None
-        raise error.Abort(_('evolution extension require rebase extension.'))
+        raise error.Abort(_('evolution extension requires rebase extension.'))
 
     for cmd in ['amend', 'kill', 'uncommit']:
         entry = extensions.wrapcommand(cmdtable, cmd,

hgext/obsolete.py

         return
 
     if not util.safehasattr(repo.opener, 'tryread'):
-        raise util.Abort('Obsolete extension require Mercurial 2.2 (or later)')
+        raise util.Abort('Obsolete extension requires Mercurial 2.2 (or later)')
     opull = repo.pull
     opush = repo.push
     olock = repo.lock