Commits

David Douard committed b922d14

obsolete: we are not compatible with 2.1 any more

  • Participants
  • Parent commits ebfd1b9

Comments (0)

Files changed (1)

File hgext/obsolete.py

     if not repo.local():
         return
 
+    if not util.safehasattr(repo.opener, 'tryread'):
+        raise util.Abort('Obsolete extension require Mercurial 2.2 (or later)')
     opull = repo.pull
     opush = repo.push
     olock = repo.lock