Changing data types for a test resets all previously recorded results.

Issue #371 resolved
Philip Au created an issue

I modified a test item from a type boolean to multiple choice, and all the previously recorded choice swapped from "yes" > "no" and vice versa.

Please be aware.

Also, is there a way to correct all the data at once? Perhaps through SQL scripting?

Thanks, Philip

Comments (8)

  1. Randle Taylor

    Hi Philip, this was fixed in v0.2.9.

    I assume your multiple choice values are "yes,no"? If you switch that to "no,yes" I think that should fix the issue.

  2. Randle Taylor

    Edit: when I say "fixed" I mean we limited test type changes in 0.2.9 since it caused issues like this. Was the reason for changing so that you could have a drop down rather than a radio button?

  3. Philip Au reporter

    I see, I will try that.

    The reason for changing the test was because we needed a tolerance value on top of the pass/action levels.

    Thanks for the quick response. Philip

  4. Randle Taylor

    Ok let me know how it goes. Tolerances for boolean values were added in 0.3.0 (after your request back in 2016).

  5. Philip Au reporter

    Just tried it, seems to have worked!

    Thanks! And I will keep this bug in mind, and will consider to upgrade as well to prevent this.

    Philip

  6. Log in to comment